import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[[^\\]]+\\]\\((?:\\s*<?https?.+>?\\s*)\\)";
final String string = "[test](https://stackoverflow.com/)\n"
+ "[test](<http://google.com>)\n"
+ "[test](<https://google.com>)\n"
+ "[test]( <http://google.com>)\n"
+ "[test\n"
+ "](\n\n"
+ "<http://google.com>\n\n"
+ ")\n"
+ "[test]( < http://google.com >)\n\n"
+ "Consider the clopen interval [0, 1).\n"
+ "We contrast this with (0, 1](I don't know why you wouldn't put a space\n"
+ "before the left parentheses...\n"
+ "but why not. Refer to https://google.com)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}