use strict;
my $str = '[test](https://stackoverflow.com/)
[test](<http://google.com>)
[test](<https://google.com>)
[test]( <http://google.com>)
[test
](
<http://google.com>
)
[test]( < http://google.com >)
Consider the clopen interval [0, 1).
We contrast this with (0, 1](I don\'t know why you wouldn\'t put a space
before the left parentheses...
but why not. Refer to https://google.com)
';
my $regex = qr/^\[[^\]]+\]\((?:\s*<?https?.+>?\s*)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}