# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[[^\]]+\]\((?:\s*<?https?.+>?\s*)\)"
test_str = ("[test](https://stackoverflow.com/)\n"
"[test](<http://google.com>)\n"
"[test](<https://google.com>)\n"
"[test]( <http://google.com>)\n"
"[test\n"
"](\n\n"
"<http://google.com>\n\n"
")\n"
"[test]( < http://google.com >)\n\n"
"Consider the clopen interval [0, 1).\n"
"We contrast this with (0, 1](I don't know why you wouldn't put a space\n"
"before the left parentheses...\n"
"but why not. Refer to https://google.com)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.