import Foundation
let pattern = #"^\[[^\]]+\]\((?:\s*<?https?.+>?\s*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[test](https://stackoverflow.com/)
[test](<http://google.com>)
[test](<https://google.com>)
[test]( <http://google.com>)
[test
](
<http://google.com>
)
[test]( < http://google.com >)
Consider the clopen interval [0, 1).
We contrast this with (0, 1](I don't know why you wouldn't put a space
before the left parentheses...
but why not. Refer to https://google.com)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)