const regex = /^\[[^\]]+\]\((?:\s*<?https?.+>?\s*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^\\]]+\\]\\((?:\\s*<?https?.+>?\\s*)\\)', 'gm')
const str = `[test](https://stackoverflow.com/)
[test](<http://google.com>)
[test](<https://google.com>)
[test]( <http://google.com>)
[test
](
<http://google.com>
)
[test]( < http://google.com >)
Consider the clopen interval [0, 1).
We contrast this with (0, 1](I don't know why you wouldn't put a space
before the left parentheses...
but why not. Refer to https://google.com)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}