re = /^\[[^\]]+\]\((?:\s*<?https?.+>?\s*)\)/m
str = '[test](https://stackoverflow.com/)
[test](<http://google.com>)
[test](<https://google.com>)
[test]( <http://google.com>)
[test
](
<http://google.com>
)
[test]( < http://google.com >)
Consider the clopen interval [0, 1).
We contrast this with (0, 1](I don\'t know why you wouldn\'t put a space
before the left parentheses...
but why not. Refer to https://google.com)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end