#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)("UserID":\s*"[A-Z0-9]+")|("CountryCode":\s*"[A-Z]+")"
Local $sString = "{" & @CRLF & _
" "EmployeeData": [" & @CRLF & _
" {" & @CRLF & _
" "UserID": "U6JDD"," & @CRLF & _
" "CountryCode": "US"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "UserID": ""," & @CRLF & _
" "CountryCode": "US"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "UserID": null," & @CRLF & _
" "CountryCode": "US"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "UserID": "U6JDD"," & @CRLF & _
" "CountryCode": """ & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "UserID": "U6JDD"," & @CRLF & _
" "CountryCode": null" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "UserID": null," & @CRLF & _
" "CountryCode": null" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")