import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"UserID\":\\s*\"[A-Z0-9]+\")|(\"CountryCode\":\\s*\"[A-Z]+\")";
final String string = "{\n"
+ " \"EmployeeData\": [\n"
+ " {\n"
+ " \"UserID\": \"U6JDD\",\n"
+ " \"CountryCode\": \"US\"\n"
+ " },\n"
+ " {\n"
+ " \"UserID\": \"\",\n"
+ " \"CountryCode\": \"US\"\n"
+ " },\n"
+ " {\n"
+ " \"UserID\": null,\n"
+ " \"CountryCode\": \"US\"\n"
+ " },\n"
+ " {\n"
+ " \"UserID\": \"U6JDD\",\n"
+ " \"CountryCode\": \"\"\n"
+ " },\n"
+ " {\n"
+ " \"UserID\": \"U6JDD\",\n"
+ " \"CountryCode\": null\n"
+ " },\n"
+ " {\n"
+ " \"UserID\": null,\n"
+ " \"CountryCode\": null\n"
+ " }\n"
+ " ]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}