// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)("UserID":\s*"[A-Z0-9]+")|("CountryCode":\s*"[A-Z]+")"#).unwrap();
let string = "{
\"EmployeeData\": [
{
\"UserID\": \"U6JDD\",
\"CountryCode\": \"US\"
},
{
\"UserID\": \"\",
\"CountryCode\": \"US\"
},
{
\"UserID\": null,
\"CountryCode\": \"US\"
},
{
\"UserID\": \"U6JDD\",
\"CountryCode\": \"\"
},
{
\"UserID\": \"U6JDD\",
\"CountryCode\": null
},
{
\"UserID\": null,
\"CountryCode\": null
}
]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}