using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""UserID"":\s*""[A-Z0-9]+"")|(""CountryCode"":\s*""[A-Z]+"")";
string input = @"{
""EmployeeData"": [
{
""UserID"": ""U6JDD"",
""CountryCode"": ""US""
},
{
""UserID"": "",
""CountryCode"": ""US""
},
{
""UserID"": null,
""CountryCode"": ""US""
},
{
""UserID"": ""U6JDD"",
""CountryCode"": ""
},
{
""UserID"": ""U6JDD"",
""CountryCode"": null
},
{
""UserID"": null,
""CountryCode"": null
}
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}