re = /("UserID":\s*"[A-Z0-9]+")|("CountryCode":\s*"[A-Z]+")/m
str = '{
"EmployeeData": [
{
"UserID": "U6JDD",
"CountryCode": "US"
},
{
"UserID": "",
"CountryCode": "US"
},
{
"UserID": null,
"CountryCode": "US"
},
{
"UserID": "U6JDD",
"CountryCode": ""
},
{
"UserID": "U6JDD",
"CountryCode": null
},
{
"UserID": null,
"CountryCode": null
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end