import re
regex = re.compile(r"(\"UserID\":\s*\"[A-Z0-9]+\")|(\"CountryCode\":\s*\"[A-Z]+\")", flags=re.MULTILINE)
test_str = ("{\n"
" \"EmployeeData\": [\n"
" {\n"
" \"UserID\": \"U6JDD\",\n"
" \"CountryCode\": \"US\"\n"
" },\n"
" {\n"
" \"UserID\": \"\",\n"
" \"CountryCode\": \"US\"\n"
" },\n"
" {\n"
" \"UserID\": null,\n"
" \"CountryCode\": \"US\"\n"
" },\n"
" {\n"
" \"UserID\": \"U6JDD\",\n"
" \"CountryCode\": \"\"\n"
" },\n"
" {\n"
" \"UserID\": \"U6JDD\",\n"
" \"CountryCode\": null\n"
" },\n"
" {\n"
" \"UserID\": null,\n"
" \"CountryCode\": null\n"
" }\n"
" ]\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")