$re = '/("UserID":\s*"[A-Z0-9]+")|("CountryCode":\s*"[A-Z]+")/m';
$str = '{
"EmployeeData": [
{
"UserID": "U6JDD",
"CountryCode": "US"
},
{
"UserID": "",
"CountryCode": "US"
},
{
"UserID": null,
"CountryCode": "US"
},
{
"UserID": "U6JDD",
"CountryCode": ""
},
{
"UserID": "U6JDD",
"CountryCode": null
},
{
"UserID": null,
"CountryCode": null
}
]
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);