package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?}`)
var str = `{&var} --> Variable stored in a dictionary --> dict("var")
{$prop} --> Property of a class cls.prop read by CallByName and PropGet
{#const} --> Some constant values by name from a function
Value of foo is '{&var:DD.MM.YYYY}' and bar is '{$prop}'
Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{$prop}'
Value of foo is '{&var:DD.\{MM\}.YYYY}' and bar is '{$prop}'
This should not match '\{&var:DD.\{MM\}.YYYY\}' but this one '{&var:DD.\{MM\}.YYYY}'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}