import re
regex = re.compile(r"((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?}", flags=re.MULTILINE)
test_str = ("{&var} --> Variable stored in a dictionary --> dict(\"var\")\n"
"{$prop} --> Property of a class cls.prop read by CallByName and PropGet\n"
"{#const} --> Some constant values by name from a function\n"
"Value of foo is '{&var:DD.MM.YYYY}' and bar is '{$prop}'\n"
"Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{$prop}'\n"
"Value of foo is '{&var:DD.\\{MM\\}.YYYY}' and bar is '{$prop}'\n"
"This should not match '\\{&var:DD.\\{MM\\}.YYYY\\}' but this one '{&var:DD.\\{MM\\}.YYYY}'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")