const regex = /((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:^|[^\\\\\\n])(?:\\\\{2})*)\\{([#$&])([\\w.]+)(?::([^}\\\\]*(?:\\\\.[^}\\\\]*)*))?}', 'gm')
const str = `{&var} --> Variable stored in a dictionary --> dict("var")
{\$prop} --> Property of a class cls.prop read by CallByName and PropGet
{#const} --> Some constant values by name from a function
Value of foo is '{&var:DD.MM.YYYY}' and bar is '{\$prop}'
Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{\$prop}'
Value of foo is '{&var:DD.\\{MM\\}.YYYY}' and bar is '{\$prop}'
This should not match '\\{&var:DD.\\{MM\\}.YYYY\\}' but this one '{&var:DD.\\{MM\\}.YYYY}'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}