re = /((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?}/m
str = '{&var} --> Variable stored in a dictionary --> dict("var")
{$prop} --> Property of a class cls.prop read by CallByName and PropGet
{#const} --> Some constant values by name from a function
Value of foo is \'{&var:DD.MM.YYYY}\' and bar is \'{$prop}\'
Value of foo is \'{&var:DD.{MM}.YYYY}\' and bar is \'{$prop}\'
Value of foo is \'{&var:DD.\\{MM\\}.YYYY}\' and bar is \'{$prop}\'
This should not match \'\\{&var:DD.\\{MM\\}.YYYY\\}\' but this one \'{&var:DD.\\{MM\\}.YYYY}\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end