import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^|[^\\\\\\n])(?:\\\\{2})*)\\{([#$&])([\\w.]+)(?::([^\\}\\\\]*(?:\\\\.[^\\}\\\\]*)*))?\\}";
final String string = "{&var} --> Variable stored in a dictionary --> dict(\"var\")\n"
+ "{$prop} --> Property of a class cls.prop read by CallByName and PropGet\n"
+ "{#const} --> Some constant values by name from a function\n"
+ "Value of foo is '{&var:DD.MM.YYYY}' and bar is '{$prop}'\n"
+ "Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{$prop}'\n"
+ "Value of foo is '{&var:DD.\\{MM\\}.YYYY}' and bar is '{$prop}'\n"
+ "This should not match '\\{&var:DD.\\{MM\\}.YYYY\\}' but this one '{&var:DD.\\{MM\\}.YYYY}'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}