// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?}").unwrap();
let string = "{&var} --> Variable stored in a dictionary --> dict(\"var\")
{$prop} --> Property of a class cls.prop read by CallByName and PropGet
{#const} --> Some constant values by name from a function
Value of foo is '{&var:DD.MM.YYYY}' and bar is '{$prop}'
Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{$prop}'
Value of foo is '{&var:DD.\\{MM\\}.YYYY}' and bar is '{$prop}'
This should not match '\\{&var:DD.\\{MM\\}.YYYY\\}' but this one '{&var:DD.\\{MM\\}.YYYY}'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}