#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<=-)|(?<=-\w)|(?<=-\w{2}))\w"
Local $sString = "asd-wqe ffvrf" & @CRLF & _
"asd-ss sd" & @CRLF & _
"a-word" & @CRLF & _
"a-verylongword" & @CRLF & _
"an-extremelyverylongword"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)