use strict;
my $str = 'asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword';
my $regex = qr/(?:(?<=-)|(?<=-\w)|(?<=-\w{2}))\w/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";