import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=-)|(?<=-\\w)|(?<=-\\w{2}))\\w";
final String string = "asd-wqe ffvrf\n"
+ "asd-ss sd\n"
+ "a-word\n"
+ "a-verylongword\n"
+ "an-extremelyverylongword";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}