const regex = new RegExp('(?:(?<=-)|(?<=-\\w)|(?<=-\\w{2}))\\w', 'gm')
const str = `asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);