$re = '/(?:(?<=-)|(?<=-\w)|(?<=-\w{2}))\w/m';
$str = 'asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;