re = /(?:(?<=-)|(?<=-\w)|(?<=-\w{2}))\w/m
str = 'asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result