using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=-)|(?<=-\w)|(?<=-\w{2}))\w";
string substitution = @"*";
string input = @"asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}