# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\p{L}*(\p{L})\1{2}\p{L}*//gm;t' <<< "This is a baaaad unnnnecessary short word"