const regex = new RegExp('\\s*\\p{L}*(\\p{L})\\1{2}\\p{L}*', 'gm')
const str = `This is a baaaad unnnnecessary short word`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);