using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\p{L}*(\p{L})\1{2}\p{L}*";
string substitution = @"";
string input = @"This is a baaaad unnnnecessary short word";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}