import re
regex = re.compile(r"\s*\p{L}*(\p{L})\1{2}\p{L}*", flags=re.MULTILINE)
test_str = "This is a baaaad unnnnecessary short word"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)