# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\\\(?!\\)/\\/g;t' <<< "\\number
\\A
\\b
\\B
\\d
\\D
\\s
\\S
\\w
\\W
\\Z
"