const regex = new RegExp('\\\\\\\\(?!\\\\)', 'g')
const str = `\\\\number
\\\\A
\\\\b
\\\\B
\\\\d
\\\\D
\\\\s
\\\\S
\\\\w
\\\\W
\\\\Z
`;
const subst = `\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);