using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\\(?!\\)";
string substitution = @"\\";
string input = @"\\number
\\A
\\b
\\B
\\d
\\D
\\s
\\S
\\w
\\W
\\Z
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}