re = /\\\\(?!\\)/
str = '\\\\number
\\\\A
\\\\b
\\\\B
\\\\d
\\\\D
\\\\s
\\\\S
\\\\w
\\\\W
\\\\Z
'
subst = '\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result