use strict;
my $str = '\\\\number
\\\\A
\\\\b
\\\\B
\\\\d
\\\\D
\\\\s
\\\\S
\\\\w
\\\\W
\\\\Z
';
my $regex = qr/\\\\(?!\\)/p;
my $subst = '\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";