$re = '/\\\\\\\\(?!\\\\)/';
$str = '\\\\number
\\\\A
\\\\b
\\\\B
\\\\d
\\\\D
\\\\s
\\\\S
\\\\w
\\\\W
\\\\Z
';
$subst = "\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;