import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^(.{22}|.{41}|.{45}|.{53}|.{64}))";
final String string = "USERNAME SESSIONNAME ID STATE IDLE TIME LOGON TIME\n"
+ "username console 9 Active 4:22 3/24/2023 8:02 AM\n"
+ "username 9 Active 4:22 3/24/2023 8:02 AM";
final String subst = "\\t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}