re = /(?<=^(.{22}|.{41}|.{45}|.{53}|.{64}))/m
str = 'USERNAME SESSIONNAME ID STATE IDLE TIME LOGON TIME
username console 9 Active 4:22 3/24/2023 8:02 AM
username 9 Active 4:22 3/24/2023 8:02 AM'
subst = '\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result