use strict;
my $str = 'USERNAME SESSIONNAME ID STATE IDLE TIME LOGON TIME
username console 9 Active 4:22 3/24/2023 8:02 AM
username 9 Active 4:22 3/24/2023 8:02 AM';
my $regex = qr/(?<=^(.{22}|.{41}|.{45}|.{53}|.{64}))/mp;
my $subst = '\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";