package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(#?\s*#?[\d]{1,2}\s*[\.\-\s,_):]?\s*|\r\n)\b`)
var str = `#1 .cisplatin #3. doxorubicin
#2 etoposide #4 asdasd
#1. adasd
#20. asd
#1 cisplatin #30. doxorubicin 6:asdasdas
#2 . etoposide #4. adasdasd
12 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}