const regex = /\b(#?\s*#?[\d]{1,2}\s*[\.\-\s,_):]?\s*|\r\n)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(#?\\s*#?[\\d]{1,2}\\s*[\\.\\-\\s,_):]?\\s*|\\r\\n)\\b', 'gi')
const str = `#1 .cisplatin #3. doxorubicin
#2 etoposide #4 asdasd
#1. adasd
#20. asd
#1 cisplatin #30. doxorubicin 6:asdasdas
#2 . etoposide #4. adasdasd
12 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}