$re = '/\b(#?\s*#?[\d]{1,2}\s*[\.\-\s,_):]?\s*|\r\n)\b/i';
$str = '#1 .cisplatin #3. doxorubicin
#2 etoposide #4 asdasd
#1. adasd
#20. asd
#1 cisplatin #30. doxorubicin 6:asdasdas
#2 . etoposide #4. adasdasd
12 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);