// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(#?\s*#?[\d]{1,2}\s*[\.\-\s,_):]?\s*|\r\n)\b").unwrap();
let string = "#1 .cisplatin #3. doxorubicin
#2 etoposide #4 asdasd
#1. adasd
#20. asd
#1 cisplatin #30. doxorubicin 6:asdasdas
#2 . etoposide #4. adasdasd
12 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}