# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(#?\s*#?[\d]{1,2}\s*[\.\-\s,_):]?\s*|\r\n)\b"
test_str = ("#1 .cisplatin #3. doxorubicin\n"
"#2 etoposide #4 asdasd\n\n"
"#1. adasd\n"
"#20. asd\n"
"#1 cisplatin #30. doxorubicin 6:asdasdas\n"
"#2 . etoposide #4. adasdasd\n"
"12 ")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.