import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(#?\\s*#?[\\d]{1,2}\\s*[\\.\\-\\s,_):]?\\s*|\\r\\n)\\b";
final String string = "#1 .cisplatin #3. doxorubicin\n"
+ "#2 etoposide #4 asdasd\n\n"
+ "#1. adasd\n"
+ "#20. asd\n"
+ "#1 cisplatin #30. doxorubicin 6:asdasdas\n"
+ "#2 . etoposide #4. adasdasd\n"
+ "12 ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}