use strict;
my $str = '#1 .cisplatin #3. doxorubicin
#2 etoposide #4 asdasd
#1. adasd
#20. asd
#1 cisplatin #30. doxorubicin 6:asdasdas
#2 . etoposide #4. adasdasd
12 ';
my $regex = qr/\b(#?\s*#?[\d]{1,2}\s*[\.\-\s,_):]?\s*|\r\n)\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}