#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\%date\%)(\d{4}-\d{1,2}-\d{1,2})((T)(\d{1,2}\:\d{1,2}))?\#([a-zA-Z]+)?"
Local $sString = "%date%2023-11-30#" & @CRLF & _
"%date%2023-11-30T00:12#" & @CRLF & _
"%date%2023-11-30#Berlin" & @CRLF & _
"%date%2023-11-30T12:12#Portugal" & @CRLF & _
"" & @CRLF & _
"// error:" & @CRLF & _
"%date%#T12:12#" & @CRLF & _
"%date%2023-11-30#1131231Portugal" & @CRLF & _
"%date%2023-11-30T12:12#Portugal123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")