import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\%date\\%)(\\d{4}-\\d{1,2}-\\d{1,2})((T)(\\d{1,2}\\:\\d{1,2}))?\\#([a-zA-Z]+)?";
final String string = "%date%2023-11-30#\n"
+ "%date%2023-11-30T00:12#\n"
+ "%date%2023-11-30#Berlin\n"
+ "%date%2023-11-30T12:12#Portugal\n\n"
+ "// error:\n"
+ "%date%#T12:12#\n"
+ "%date%2023-11-30#1131231Portugal\n"
+ "%date%2023-11-30T12:12#Portugal123\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}