// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\%date\%)(\d{4}-\d{1,2}-\d{1,2})((T)(\d{1,2}\:\d{1,2}))?\#([a-zA-Z]+)?").unwrap();
let string = "%date%2023-11-30#
%date%2023-11-30T00:12#
%date%2023-11-30#Berlin
%date%2023-11-30T12:12#Portugal
// error:
%date%#T12:12#
%date%2023-11-30#1131231Portugal
%date%2023-11-30T12:12#Portugal123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}