package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\%date\%)(\d{4}-\d{1,2}-\d{1,2})((T)(\d{1,2}\:\d{1,2}))?\#([a-zA-Z]+)?`)
var str = `%date%2023-11-30#
%date%2023-11-30T00:12#
%date%2023-11-30#Berlin
%date%2023-11-30T12:12#Portugal
// error:
%date%#T12:12#
%date%2023-11-30#1131231Portugal
%date%2023-11-30T12:12#Portugal123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}